Error Message

Working with Digital Design Tools

csa_marvin on 08/20/2014 02:15

Here is guide to help users unfamiliar with LDD prepare a model for submission.

 

Required Files

Getting Started

  • When you open LDD for the first time, you will be presented with three different building options.
  • It is recommended to choose the third option: LEGO® Digital Designer Extended.
     - LDD Extended gives the most freedom with access to almost every brick available!

  • Once you have selected LEGO® Digital Designer Extended, click on the “Free Build” icon at the bottom.
     - Use the “Open another file” icon when you would like to return to builds you have already started.

 

Configuring LEGO® Digital Designer

  • Before starting to build, it is a good idea to configure some LDD preferences for a better experience.
  • You can access your LDD Preferences by:
                  - For Windows Users: Go to Edit > Preferences or press  Ctrl+6.
                  - For Mac Users: Go to LEGO Digital Designer > Preferences or press Cmd+,
  • The most important setting to activate is the “Outlines on brick”.  
                  - This setting will make it easier to differentiate adjacent bricks of the same color.
                  - You MUST restart the program before changes take place.

If you notice slow performance, try disabling the settings that mention “High-quality rendering”.

 

The Three Modes of LEGO® Digital Designer

  • In LEGO® Digital Designer, there are three modes of operation 

Build Mode
Build and edit your model using vertual bricks on a virtual scene.

View Mode
Play with some tools to change the background, explode your model or take a screenshot.

Building Guide Mode
Generate auto instructions of your model which can also be saved as an html file.

  • You can switch between these three modes by clicking on the corresponding icons at the top right.
                  - Building Guide Mode is not available until you place at least one brick down.

 

Camera Controls

  • LEGO® Digital Designer provides an interactive surface to build models called a scene.
  • Several camera controls are located in the scene that you can use to better view your model.

Interface Camera Controls

 

 

 

 

 

Mouse Camera Controls

You can also use your mouse to control the scene camera as well.    

  • Hold down the Right Mouse Button to use the mouse to freely rotate the scene.    
  • Click the Right Mouse Botton on any brick to center it in the scene.    
  • Scroll up or down the Mouse Scroll Wheel to zoom in and out of the scene.    
  • Hold down the Shift Key + Right Mouse Button to use the mouse to pan the scene.

 

Main Icon Bar

  • Some important project related functions exist in the Main Icon Bar available to you in the Build Mode.

* Each mode of LEGO® Digital Designer has its own unique Main Icon Bar with different icons.

 

Placing Bricks In the Scene

  • Take a look at the Building Palette on the left side where you will find the bricks needed to build.
  • To get started, simply click on the desired brick category to expand it.

- If you already know what brick you want, make use of the search function.

Tip: You can search using part numbers!
 

  • Once you have chosen your first brick to lay down, click on it to to begin the placement process.


1. Click on desired brick.                                2. Move brick with mouse and change orientation with arrow keys.
                                                                       3. Click once more to place the brick in the scene.

  • LEGO® Digital Designer has the cool ability to detect connections and collisions between bricks.            
                  - While moving a brick around to place, any valid connection will be highlighted green.            
                  - Any illegal connections will be greyed out and will prevent the brick from being placed.
                    
  • In order to move a brick that has been already placed, click and drag the brick to reposition it.

Building Your Model

  • Building tools are limited to the Build Mode only. Different tools are present for each mode.
  • Some tools come with additional contextual tools found below the main toolbar. 

 

Selection Tool      keyboard Shortcut: V

This tool allows you to select a single brick in the scene. You can also click and drag a window that will select all bricks that are completely inside of it.

Multiple Selection: Select multiple bricks at a time.

Connected Selection: Select all bricks connected to the selected brick including itself.

Color Selection: Select all bricks of the same color as the brick selected.

Shape Selection: Select all bricks of the same exact shape as the brick selected.

Color & Shape Selection: Select all bricks of the same shape and color as the brick selected.

Invert Selection: Select every other brick besides the one already selected.

 

Clone Tool      Keyboard Shortcut: C

This tool allows you to make a duplicate of the selected brick. You can also use this tool after any Selection Tool to make duplicates of multiple selections as well.

Hinge Tool      Keyboard Shortcut: H
This tool allows you rotate a single or group of bricks as long as it has a valid connection to another brick that allows for movement (ie. bricks connected to a single stud or clip).

 

 

 

 

 

 

 

- A single stud connection is enough to use the Hinge Tool. Experiment with different connections!

 

 

 

 

- You can rotate a group of bricks at once if it is attached by a valid connection allowing movement. 
               - A red bounding box will always let you know what brick(s) are being affected.

 

 

 


- You can manually enter precise values in the contextual toolbar while rotating a brick.

* Keep in mind the brick must be first connected to another brick in order to use the Hinge Tool on it.

Hinge Aligh Tool      Keyboard Shortcut: Shift+H

This tool has very conditional uses but it can quickly bring two connection points together. It is an automated process which requires you to select two compatible connections to work.

 

 

 


 

  1. Activate the Hinge Align Tool and click one of the connection points to be joined.
    - Green directional arrows will let you know what connection point is being focused.
  2. Click on the other desired connection point you would like the first connection point to join to.
  3. If the tool has been used correctly, the bricks auto-move to complete the desired connection.

* The Hinge Align Tool can be helpful to use working with clips and Technic pins. 

Flex Tool      Keyboard Shortcut: F

This tool allows you to bend and twist flexible bricks that you have placed in the scene. Bricks that are flexible will have a small icon()next to them in the Brick Palette. 

 

 

 

 

 

  1. Anchor one end of a flexible to an existing brick.
  2. Using the Flex Tool, click on the free end of the flexible brick. It should now follow your mouse. 
  3. Complete the process by clicking the stud/connection you would like to link it to.
    - Possible connections will be highlighted in green as you mouse over them.

Paint Tool      Keyboard Shortcut: B

This tool allows you to change the color and transparency settings of any brick in the scene. You can also use this tool to add decorations to select pieces that allow for it. 



Paint Tool: Click on a brick to apply the selected color or transparency.

Color Selection: Select a color from a palette to use your Paint Tool with.

Color Picker: Change the color selection to that of the brick you select in the scene.

Decoration: Apply a decoration to a compatible brick you select in the scene. (ie. minifig. head)

 

Hide Tool      Keyboard Shortcut: L

This tool allows you to temporarily hide selected bricks from the scene. It is helpful to hide bricks that would normally block your vision or ones that you are no longer concentrating on.



Once you select a brick to hide, this icon will appear on the top right corner of the scene. Click on this icon to show all bricks that have been hidden.

 

Delete Tool      Keyboard Shortcut: D

This tool allows you to delete any brick you click in the scene. Like the Clone Tool, you may use this tool after any Selection Tool to also delete multiple bricks at once.

 

Templates and Groups

In the Template Palette, you can save any selection of bricks as a permanent assembly that is available for use every time you launch LEGO® Digital Designer.


 

- After selecting the assembly of bricks you want to save as a template, click on the “Create Template” icon at the bottom of the palette. ​

 

 

- This will crea te an image  preview of the template in the Template Palette that can be clicked on to place in any scene.

- Press the red “X” next to the template image preview to delete it.

 

In the Grouping Palette, you can save any selection of bricks as a group that will be used for the current project only. This is very useful to organize and add hierarchy to bricks in a model.

- After selecting the bricks you want to save as a group, click on the “Create Group” icon at the bottom of the palette.

 

 

- This will create an image preview of the group and additional icons that can be used to edit the group or create a subgroup.

Add selected bricks to the existing group.

Remove selected bricks from the existing group.

Create a subgroup out of the selected bricks.

- You can use the Selection Tool to select all members of a group easily by just clicking on the group image preview.

 

 

 

LDraw Compatability

  • For users with LDraw experience, LDD has the ability to directly import and export LDraw files (*.ldr).  

Import
- Windows and Mac Users: Go to File > Import and choose the LDraw file to open.
Export
- Windows and Mac Users: Go to File > Export and choose a name to save as.
- Make sure to specify the format as “LDraw-Files (*.ldr)” before exporting.